Bug Reports

Create New

Votes Subject Text State Created Closed Author
0 XMI-Export: ActivityNodes not contained in ExpansionRegions If I place an ActivityNode in an ExpansionRegion there are no references in the exported XMI-file... Solved 28 September 2012 30 September 2012 Waldemar Details
0 Wrong z-order for Sequence Diagram's Self Message text Hi, I a sequence diagram, if I drag a Self Message onto a Lifeline which doesn't have an Activ... Solved 24 September 2012 30 September 2012 JKSH Details
0 XMI-Export: Wrong pins and doubled references In this example the Action should receive Objects from 2 ObjectFlows through the Pin so the Pin s... Solved 24 September 2012 30 September 2012 Waldemar Details
0 ExpansionNodes missing in XMI-Export there are references leading to it but the ExpansionNode itself is missing Solved 24 September 2012 30 September 2012 Waldemar Details
0 static operations not showing in php code generator I created a operation(method) as static in a class and created a PHP class using generator.The re... Solved 18 September 2012 30 September 2012 Anantha Details
0 Statechart transition arrow The transition arrow has a "/" upon creation, that is fine However, when I double click on the... Solved (in 5.50) 8 September 2012 16 September 2012 Allan Chong Details
0 Opening Tool -> List -> Types throw exception After adding some own types to the lists, the next step I wasn't able to edit them anymore: Sy... Solved (in 5.50) 5 September 2012 16 September 2012 W Poirters Details
0 Can't undo movement of Control Flow arrow labels (Activity Diagram) Hi, The effects of RQ #86 haven't carried over to Control Flow arrows, it seems. I remember re... Solved (in 5.50) 3 September 2012 16 September 2012 JKSH Details
0 Activity Diagram does not save Fork/Join bar rotation Hi, After I save an activity diagram with rotated Fork/Join bars, when I close and re-open the... Solved (in 5.50) 3 September 2012 16 September 2012 JKSH Details
0 Resize-handles of fork/join elements don't rotate (Activity Diagram) Hi, A fork or join element is initially horizontal, so I need to drag its left/right handles t... Solved (in 5.50) 3 September 2012 16 September 2012 JKSH Details
0 Textbox border not showing When I open a textbox, and selects its border.. the border does not show it is always invisibl... Solved (in 5.50) 19 August 2012 16 September 2012 Allan Details
0 Problem on Interface extending The source code generator doesn't including an interface super classes in PHP code. Solved (in 5.50) 9 August 2012 16 September 2012 Arvand Details
0 Crash when no network connection When there is no network connection available and SIM is configured to automatically check for up... Solved (in 5.50) 2 August 2012 16 September 2012 Lars Kemmann Details
0 Long diagram names are clipped in the Model Overview window Hi Dušan, thanks for all the new features and fixes in version 5.40! It feels smoother to use now... Solved (in 5.50) 31 July 2012 16 September 2012 Jeremy Details
0 Version 5.40 Crashes on Launch I've been running SIM for quite awhile. I am not sure what the last working version was but abou... Solved 29 July 2012 11 April 2013 Paul Menefee Details
0 While drawing interface mockup program hangs. Program hang while moving multiple selection. Description: A problem caused this program to... Cannot Reproduce 25 July 2012 16 April 2013 Kevin Anderson Details
0 Clicking on an Interaction Operand causes it transfer to a parent fragment Hi, In a sequence diagram, I had and Alt fragment, and put an Opt fragment inside it. I put an... Solved (in 5.40) 14 July 2012 22 July 2012 Jeremy Details
0 NullReferenceException caused by Ctrl+W when no windows are open 1. Open SIM 2. Close the Start Page 3. Call Windows->Close (Ctrl+W) again The system encount... Solved (in 5.40) 13 July 2012 22 July 2012 Jeremy Details
0 Undo delete restores boxes in the wrong order Hi, In a class diagram, I had a Package containing 1 Class with 2 sub-Classes. I deleted th... Solved (in 5.40) 13 July 2012 22 July 2012 Jeremy Details
0 ExpansionRegion & Pins XMI-Export references to the contained nodes are missing in the xmi-file. And pins are missing too. Solved (in 5.40) 11 July 2012 22 July 2012 Waldemar Details