User Manual for Software Ideas Modeler

This section offers articles and topics which explains the particular parts of Software Ideas Modeler - ribbon and menu actions, sidebars, options and settings and template language commands.

First Steps

Installation

Software Ideas Modeler needs for its run installed .NET Framework 4.5.2.

How to Change Edition of Software Ideas Modeler

Software Ideas Modeler offers various editions that include different subsets of all features. During the evaluation period, you may try any of the offered editions and find the one which suits your needs best.

How to Apply Your License Key

The following steps show you how to apply your license you get to e-mail after your purchase.

First Steps with Software Ideas Modeler

You have installed Software Ideas Modeler and you want to start to work with it. This article guides you through the first steps after running the application.

Software Ideas Server Setup

Server provides support for user cooperation, global repository and tasks.

Uninstallation

Removing Software Ideas Modeler from your computer is very easy.

Beginning with Software Ideas Modeler

Day 1: First Steps with Software Ideas Modeler

This tutorial will show you how to start with Software Ideas Modeler, how to create a new project, save it and open the existing ones. It describes the main user interface layout and its components.

Day 2: Drawing Diagrams

The key activity in Software Ideas Modeler you would like to master is diagramming. This tutorial shows how to grasp basic concepts and how easy it is to create diagrams.

Day 3: Basic Diagramming Operations

If you want to create models and diagrams, you need to handle the basic diagramming operation - selecting elements, renaming them, mastering the work with the clipboard to copy and paste the elements. It is also good to know how to delete the diagram elements properly.

Day 4: Choosing Right Diagram Type

Software Ideas Modeler is a diagramming software which supports plenty of diagram types and standards. However, what diagram should be used in the given scenario? What diagram would be most useful for the specific task?

Day 5: Exporting Your Work for Others

The diagrams and models you created may be presented to the outside world in standard format files. You may print the diagrams, send projects via email or create the whole documentations.

Day 6: Mastering the Layout and Arrangement

A good layout makes a good diagram. Software Ideas Modeler provides a lot of tools that help you to create beautiful diagrams with a perfect layout.

Day 7: Styling Diagram Elements

Software Ideas Modeler offers plenty of styling options and settings. You may choose your colors and fonts, adjust the border width, the fill style, turn on shadows or gloss effects. An emulated handwriting style is also supported. It is possible to adjust the styles of individual elements. You may also extract these styles and reuse them.

Day 8: Editing Element Properties

Each element is defined by its properties - id, name, style, owner, repository, associated diagrams, tagged values, documentation. and other element-specific properties. You may edit all of them using the Properties dialog and a lot of them in the Properties sidebar.

Day 9: Drag & Drop

Drag and drop is a very useful and intuitive technique. Software Ideas Modeler supports drag&drop actions wherever it is possible.

Day 10: Project Hierarchy

The models and diagrams are organized in projects. A project contains all elements, relationships, documentation, diagrams, other specific parts, and their associated data, fields and styling settings.

Ribbon

Home (Ribbon Tab)

Home tab offers the common and most used editing actions, which include work with clipboard, text and element formatting, styling, basic arrange actions, selection, search and replace.

Insert (Ribbon Tab)

Insert ribbon tab includes several actions for insertion of new contents to the active project.

Design (Ribbon Tab)

Design ribbon tab contains various actions for layout and arranging. It also provides a tools for work with style sets.

Project (Ribbon Tab)

Project ribbon tab offers actions for editing project structure and project level lists.

Diagram (Ribbon Tab)

Diagram ribbon tab provides actions for editing diagram properties, managing layers, filtering diagram content, setting its format and also tools for further processing.

Review (Ribbon Tab)

Review ribbon tab contains tools for project comparison, change tracking and some specialized helper tools.

Process (Ribbon Tab)

Process ribbon tab provides tools for reverse engineering diagrams from various sources (code, database), source code and documentation generation, template and global list management.

View (Ribbon Tab)

View ribbon tab provides application environment settings, access to project model, open windows and tools for handling macros.

File (Ribbon Tab)

The file tab contains the main actions which allows you to start your work and later to save the result or creates another output from the existing project using print/export actions.

Model (Ribbon Tab from Element Context Group)

If you select an element, another context tabs will be shown. One of these tabs is Model tab in Element context group. It allows you to adjust the model of the selected element(s).

Menu

File Menu

The file menu contains the main actions, which allows to start work and later to save the result of done work or creates the other output using print/export actions.

Edit Menu

The edit menu allows to manipulate elements in the editor area.

View Menu

The View menu allows to set custom preferences of application user interface.

Project Menu

The Project menu provides commands for work with project structure and its content.

Diagram Menu

The Diagram menu allows to perform actions on the current active diagram and adjust its settings.

Element Menu

The Element menu allows to perform actions on the selected element(s).

Arrange Menu

The Arrange menu provides commands, which help to adjust the bounds and alignments of elements and the layout of the whole diagram.

Tools Menu

The Tools menu provides various specialized tools. It allows to generate documentation, source code, do reverse engineering, edit lists and set application options.

Windows Menu

The Windows menu provides commands which allow you to manipulate the open child window.

Help Menu

The Help menu provides the access to help and to the information about the product.

Text Menu

Text menu offers actions for work with formatted text. The actions affect the active formatted text whether it is in a diagram, in a sidebar or as a tab with documentation.

Sidebars

Project Tree Sidebar

Project Tree sidebar allows to browse the models, diagrams, and elements of the project and to add, move, order or delete these project item.

Properties Sidebar

Properties sidebar allows to change some basic properties of the selected element.

Styles Sidebar

Styles sidebar contains the list with defined styles and buttons which allow to work with the current style set and its styles.

Generation Sidebar

Generation sidebar helps you with source code generation in various languages. You can generate source code for the current diagram or the selected elements.

Fast Editor Sidebar

The Fast editor allows you to textually edit the selected element - adjust its name, stereotypes, attributes, operations, etc.

Style Sidebar

Style sidebar allows you to adjust the appearance of the current selected element. You can change background, border, fonts and other style parameters.

Documentation Sidebar

Documentation sidebar allows you to set a formatted description for any element in a diagram and for the diagram itself.

Layers Sidebar

Layers sidebar allows you to add, remove and reorder the layers of diagram. Each diagram can be divided in multiple layers, which can be easily shown or hidden.

To-Do Sidebar

To-Do sidebar allows you to add, manage and organize your to-do tasks in a simple list. These tasks are assigned to the current project.

Design Patterns Sidebar

Design Patterns sidebar allows you to create your custom design patterns from selected elements in the diagram or to apply existing design patterns from the list.

Field Patterns Sidebar

Field Patterns sidebar allows you to apply existing field patterns to elements, add new custom field patterns or delete the existing ones.

Parser Sidebar

Parser sidebar allows you to easily turn your source code into diagram elements.

Graphics Sidebar

Graphics sidebar contains the list of shapes you can add to the diagram using drag and drop.

Cooperation Sidebar

Cooperation sidebar allows you to work with the list of persons and to filter the content of the active diagram.

Preview Sidebar

Preview sidebar displays a thumbnail of the active diagram and it highlights the current viewing area with the semitransparent rectangle.

Options and Settings

General Tab

General tab contains general application settings and options (user interface settings, language, etc.)

Save Tab

Save tab offers settings for backups and exports.

User Profile Tab

User Profile tab allows you to define your user profile, which allows to identify your project files.

Diagram Editor Tab

Diagram Editor tab allows to adjust diagram editor behavior and appearance.

Project Tree Tab

Project Tree tab handles the settings of the project tree.

E-mail Tab

E-mail tab allows to set preferences about e-mail sending.

Update Tab

Update tab allows to set the way how you want to handle new versions of Software Ideas Modeler.

Menu Tab

Menu tab allows to set custom shortcut keys for any menu item.

Template Language

Relation Type Commands (Template Language)

Commands for objects of Relation type defined in Software Ideas Modeler Template Language.

String Commands (Template Language)

String and text commands defined in Software Ideas Modeler Template Language.

Logical Commands (Template Language)

Logical boolean commands of Software Ideas Modeler template language.

GlossaryItem Type Commands (Template Language)

Commands for objects of GlossaryItem type defined in Software Ideas Modeler Template Language.

TaggedValue Type Commands (Template Language)

Commands for objects of TaggedValue type defined in Software Ideas Modeler Template Language.

OperationParameter Type Commands (Template Language)

Commands for objects of OperationParameter type defined in Software Ideas Modeler Template Language.

Operation Type Commands (Template Language)

Commands for objects of Operation type defined in Software Ideas Modeler Template Language.

Attribute Type Commands (Template Language)

Commands for objects of Attribute type defined in Software Ideas Modeler Template Language.

ERDEntityAttribute Type Commands (Template Language)

Commands for objects of ERDEntityAttribute type defined in Software Ideas Modeler Template Language.

ERDEntity Type Commands (Template Language)

Commands for objects of ERDEntity type defined in Software Ideas Modeler Template Language.

Association Type Commands (Template Language)

Commands for objects of Association type defined in Software Ideas Modeler Template Language.

Class Type Commands (Template Language)

Commands for objects of Class type defined in Software Ideas Modeler Template Language.

ModelElement Type Commands (Template Language)

Commands for objects of ModelElement type defined in Software Ideas Modeler Template Language.

DiagramElement Type Commands (Template Language)

Commands for objects of DiagramElement type defined in Software Ideas Modeler Template Language.

Diagram Type Commands (Template Language)

Commands for objects of Diagram type defined in Software Ideas Modeler Template Language.

Model Type Commands (Template Language)

Commands for objects of Model type defined in Software Ideas Modeler Template Language.

Project Type Commands (Template Language)

Commands for objects of Project type defined in Software Ideas Modeler Template Language.

Basic Commands (Template Language)

Basic commands of Software Ideas Modeler template language.